Raster Editor



Description:

The raster editor toolbar provides tools to perform pixel edits on a raster dataset. A copy of the selected raster is made into a default location and all edits go into the copy. At any point, the edit dataset can be saved to another location.

Currently, the tools are designed to work with integer grids with a unique value renderer. Multi-band raster editing is not supported. Also, when starting a raster edit session, a copy of the raster is created in a default directory. Once the edits have been made to the raster, it should be moved to another directory, because when a new edit session is started with a different raster the copy of the raster residing in the default directory will be overwritten.

Currently up to 25 edits made to raster can be undone. To undo or redo an edit use the undo and redo tools already provided in ArcMap.
Products:
ArcView: VB6

Platforms: Windows

Minimum ArcGIS Release: 9.0

How to use:
  1. Register RasterEditorPrj.dll in ArcMap.
  2. Browse for and select the RasterEditorPrj.dll using the 'Add From File' button on the customize dialog.
  3. Go to View > Toolbars > Raster Editor to display the toolbar.
  4. Add a raster to your map.
  5. Go to the Raster Edit menu and Start Editing.
  6. A dialog will pop up listing the rasters in the map. Select a raster to edit and click OK.
  7. A copy of the raster, named RASEDDAT is created and added to the map.
  8. Use the tools on the toolbar to edit the raster (see description of toolbar functionality below to edit the raster).
  9. For more information see the included word file (Raster_Editor_Toolbar.doc).

Download the VB6 files
REEditor.bas The module containing most of the raster editing procedures used.
REPulldownItems.cls The class module for the Raster Edit Menu.
REDrawingToolSelect.cls The class module for the drawing tools.
clsSelectionTool.cls The class module for the select and paste tools.

Download the files for all languages



Key CoClasses:Raster, RasterBand, PixelBlock
Key Interfaces: IRasterBandCollection, IRasterProps, IRawPixel, IPixelBlock
Key Members:IRasterBandCollection::SaveAs, IRasterProps::Extent, IRasterProps::IsInteger, IRaster::CreatePixelBlock, IRawPixel::Read, IRawPixel::Write, IPixelBlock::SafeArray